Configuraties › Extra's - QoS

Deze configuratie gaat er vanuit dat je een werkende internet verbinding hebt en stelt QoS in voor je internetverkeer. We nemen aan dat de uplink naar je provide op ether10 zit, en dat de router DHCP doet op 10.0.0.1/24. De gateway van je netwerk is 10.0.0.254.

Configuratie


#
# LET OP
# Neem nooit de configuratie klakkeloos over, maar controleer altijd of hij ook
# helemaal klopt met je persoonlijke situatie. Ik kan niet verantwoordelijk
# gehouden worden door onjuiste configuraties etc.
#
# Dit configuratievoorbeeld komt uit een werkende opstelling met een Mikrotik
# RB2011UAS-2HnD-IN. Gebruik de configuratie als leidraad.
#


# Maak een aantal queues aan. We maken daarbij onderscheid tussen normaal (core) traffic
# en download traffic. Pas de max-limit waarden aan naar je eigen upload. Speel daarnaast
# met verschillende waarden voor burst-time, treshold en limit-at.
/queue tree
add max-limit=100M name=wan parent=global queue=default
# Prioriteer download verkeer laag
add max-limit=100M name=download-traffic packet-mark=download-traffic-packets \
    parent=wan priority=5 queue=default
# Prioriteer core traffic hoog
add burst-limit=100M burst-threshold=75M burst-time=8s limit-at=50M max-limit=80M \
    name=core-traffic packet-mark=core-traffic-packets parent=wan \
    priority=2 queue=default

# Door middel van onderstaande regels markeren we verkeer. Afhankelijk van de
# marker komen ze in 1 van de 2 queues terecht. Pas de mangle lijst aan naar je eigen
# soorten verkeer. We markeren connecties, en vervolgens alle pakketjes met de
# connection marker. Dat scheelt resources.
/ip firewall mangle

add action=mark-connection chain=prerouting comment="tcp: dns, https, telnet" \
    dst-port=53,443,23 new-connection-mark=core-traffic-connection \
    protocol=tcp src-port=""

add action=mark-packet chain=prerouting connection-mark=core-traffic-connection \
    new-packet-mark=core-traffic-packets passthrough=no

add action=mark-connection chain=prerouting comment="udp: dns" dst-port=53 \
    new-connection-mark=core-traffic-connection protocol=udp

add action=mark-packet chain=prerouting connection-mark=core-traffic-connection \
    new-packet-mark=core-traffic-packets passthrough=no

add action=mark-connection chain=prerouting comment="tcp: ssh" dst-port=22 \
    new-connection-mark=core-traffic-connection packet-size=0-1400 protocol=tcp

add action=mark-packet chain=prerouting connection-mark=core-traffic-connection \
    new-packet-mark=core-traffic-packets passthrough=no

add action=mark-connection chain=prerouting comment="tcp: http (0-500kb)" \
    connection-bytes=0-500000 dst-port="" new-connection-mark=\
    core-traffic-connection protocol=tcp src-port=80

add action=mark-packet chain=prerouting connection-mark=core-traffic-connection \
    new-packet-mark=core-traffic-packets passthrough=no

add action=mark-connection chain=prerouting comment="p2p traffic" new-connection-mark=\
    p2p-traffic-packets p2p=all-p2p

add action=mark-packet chain=prerouting new-packet-mark=p2p-traffic-packets p2p=all-p2p \
    passthrough=no

add action=mark-connection chain=prerouting comment="tcp: mail (imap, pop, smtp) + ftp" \
    dst-port=20,21,25,110,143,465,993,995 new-connection-mark=\
    download-traffic-connection protocol=tcp

add action=mark-packet chain=prerouting dst-port=20,21,25,110,143,465,993,995 \
    new-packet-mark=download-traffic-packets passthrough=no protocol=tcp

add action=mark-connection chain=postrouting comment="tcp: http downloads (500kb+)" \
    connection-bytes=500000-0 dst-port="" new-connection-mark=download-traffic-connection \
    protocol=tcp src-port=80

add action=mark-packet chain=postrouting connection-mark=download-traffic-connection \
    new-packet-mark=download-traffic-packets passthrough=no

add action=mark-connection chain=prerouting comment="tcp: video streaming (rtmp)" \
    new-connection-mark=download-traffic-connection protocol=tcp src-port=1935

add action=mark-packet chain=prerouting connection-mark=download-traffic-connection \
    new-packet-mark=download-traffic-packets passthrough=no