Configuraties › Extra's - PPTP Server

Deze configuratie gaat er vanuit dat je een werkende internet verbinding hebt en stelt een PPTP server in. We nemen aan dat de uplink naar je provide op ether10 zit, en dat de router DHCP doet op 10.0.0.1/24. De gateway van je netwerk is 10.0.0.254.

Configuratie


#
# LET OP
# Neem nooit de configuratie klakkeloos over, maar controleer altijd of hij ook
# helemaal klopt met je persoonlijke situatie. Ik kan niet verantwoordelijk
# gehouden worden door onjuiste configuraties etc.
#
# Dit configuratievoorbeeld komt uit een werkende opstelling met een Mikrotik
# RB2011UAS-2HnD-IN. Gebruik de configuratie als leidraad.
#


# Maak een PPTP server aan
/interface pptp-server
add name=pptp user=""

# Maak een PPP profiel om globale zaken in 1x in te stellen voor alle gebruikers
/ppp profile
add dns-server=10.0.0.254 local-address=10.0.0.254 name=pptp remote-address=default-dhcp

# MRU en MTU instellen voor PPTP server
/interface pptp-server server
set enabled=yes max-mru=1460 max-mtu=1460

# Sta inkomend PPTP verkeer toe (TCP 1723 en GRE)
/ip firewall filter
add chain=input comment="PPTP VPN" dst-port=1723 in-interface=ether10 protocol=tcp
add chain=input in-interface=ether10 protocol=gre

# Voeg een testgebruiker toe
/ppp secret
add name=test password=foobar profile=pptp service=pptp