Configuraties › Helden van Nu - Internet

Deze configuratie stelt je Mikrotik router in om verkeer vanaf je glasvezelmodem naar je interne netwerk te routeren.

Uitgangspunt

Schematische opstelling

Deze simpele configuratie stelt de Mikrotik zo in dat hij alleen internetverkeer afhandelt. Dit is de meest basic configuratie die mogelijk is. De configuratie gaat er vanuit dat je het glasvezelmodem op poort 10 van de router hebt aangesloten en maakt alle overige poorten geschikt om te internetten. De verbinding bij Helden van Nu werkt via PPPoE, dus die stellen we ook in.

Routerconfiguratie


#
# LET OP
# Neem nooit de configuratie klakkeloos over, maar controleer altijd of hij ook
# helemaal klopt met je persoonlijke situatie. Ik kan niet verantwoordelijk
# gehouden worden door onjuiste configuraties etc.
#
# Dit configuratievoorbeeld komt uit een werkende opstelling met een Mikrotik
# RB2011UAS-2HnD-IN, maar stelt geen Wi-Fi netwerk in. Gebruik de configuratie
# als leidraad.
#


# We maken een bridge voor al het internetverkeer
/interface bridge
add name=bridge-internet

# Zorg dat alle interfaces een correcte naam hebben
/interface ethernet
set 0 name=ether1
set 1 name=ether2
set 2 name=ether3
set 3 name=ether4
set 4 name=ether5
set 5 name=ether6
set 6 name=ether7
set 7 name=ether8
set 8 name=ether9
set 9 name=ether10

# Inbellen via PPPoE. Denk eraan je username & password in te stellen.
/interface pppoe-client
add add-default-route=yes disabled=no interface=ether10 name=pppoe password=pass user=user

# Deze configuratie gaat er vanuit dat alle apparaten via DHCP een adres krijgen.
# De DHCP server deelt adressen uit in de range 10.0.0.1-10.0.0.200.
/ip pool
add name=default-dhcp ranges=10.0.0.1-10.0.0.200

# DHCP server instellen, deel adressen uit aan alle apparaten die in
# bridge-internet zitten.
/ip dhcp-server
add address-pool=default-dhcp disabled=no interface=bridge-internet name=default

# Voeg ether1-ether9 toe aan de bridge
/interface bridge port
add bridge=bridge-internet interface=ether1
add bridge=bridge-internet interface=ether2
add bridge=bridge-internet interface=ether3
add bridge=bridge-internet interface=ether4
add bridge=bridge-internet interface=ether5
add bridge=bridge-internet interface=ether6
add bridge=bridge-internet interface=ether7
add bridge=bridge-internet interface=ether8
add bridge=bridge-internet interface=ether9

# Laat de router zelf luisteren op 10.0.0.254
/ip address
add address=10.0.0.254/24 interface=wlan1 network=10.0.0.0

# De router krijgt via de NTU een publiek adres via DHCP
/ip dhcp-client
add dhcp-options=hostname,clientid disabled=no interface=ether10

# Laat de router de DNS server en gateway zijn voor het interne netwerk
/ip dhcp-server network
add address=10.0.0.0/24 dns-server=10.0.0.254 gateway=10.0.0.254

# Stel de router in als DNS server, we gebruiken Google DNS.
/ip dns
set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4

# Stel wat klein grut in
/ip firewall connection tracking
set tcp-established-timeout=1h30m

# Timmer het apparaat dicht voor verkeer vanaf het internet
/ip firewall filter
add chain=input connection-state=related in-interface=pppoe
add chain=input connection-state=established in-interface=pppoe
add action=drop chain=input comment="Invalid packets" connection-state=invalid in-interface=pppoe
add action=drop chain=forward connection-state=invalid in-interface=pppoe
add action=reject chain=input in-interface=pppoe protocol=tcp reject-with=icmp-port-unreachable
add action=reject chain=input in-interface=pppoe protocol=udp reject-with=icmp-port-unreachable
add action=reject chain=input in-interface=pppoe protocol=icmp reject-with=icmp-admin-prohibited
add action=log chain=input comment="Log everything else" in-interface=pppoe log-prefix="DROP INPUT"

# Doe NAT op al het verkeer dat de router verlaat via pppoe
/ip firewall nat
add action=masquerade chain=srcnat out-interface=pppoe to-addresses=0.0.0.0

# Stel de tijd in via NTP
/system clock
set time-zone-name=Europe/Amsterdam
/system ntp client
set enabled=yes mode=unicast primary-ntp=194.109.22.18 secondary-ntp=194.109.20.18