Configuraties › Extra's - Hairpin NAT

Deze configuratie gaat er vanuit dat je een werkende internet verbinding hebt en stelt Hairpin NAT in, ook wel NAT loopback genoemd. Daardoor kun je een interne server bereiken op een publiek ip. We nemen aan dat je publieke IP 1.1.1.1 is, dat je interne netwerk op 10.0.0.0/24 z'n werk doet, en dat de server ip 10.0.0.1 heeft.

Configuratie


#
# LET OP
# Neem nooit de configuratie klakkeloos over, maar controleer altijd of hij ook
# helemaal klopt met je persoonlijke situatie. Ik kan niet verantwoordelijk
# gehouden worden door onjuiste configuraties etc.
#
# Dit configuratievoorbeeld komt uit een werkende opstelling met een Mikrotik
# RB2011UAS-RM. Gebruik de configuratie als leidraad.
#


/ip firewall nat
# Hairpin NAT instellen
add action=dst-nat chain=dstnat disabled=no dst-address=1.1.1.1 to-addresses=10.0.0.1
add action=src-nat chain=srcnat disabled=no src-address=10.0.0.1 to-addresses=1.1.1.1
# Shortcut: zo wordt verkeer van het interne netwerk naar de 'publieke' server
# niet over het internet gestuurd, maar direct intern afgehandeld.
add action=masquerade chain=srcnat disabled=no dst-address=10.0.0.0/24 \
    src-address=10.0.0.0/24