Configuraties › Extra's - Failover

Deze configuratie gaat er vanuit dat je een werkende internet verbinding hebt en stelt failover in. Als je 2 (of meer) verbindingen hebt en verbinding A valt weg, schakelt de router automatisch over op verbinding B. Als verbinding A weer online komt, schakelt de router automatisch weer terug. Het voorbeeld gaat er vanuit dat verbinding A een publiek IP heeft van 1.1.1.1 (Gateway 1.1.1.2) en verbinding B een publiek IP van 2.2.2.2 (Gateway 2.2.2.3)

Configuratie


#
# LET OP
# Neem nooit de configuratie klakkeloos over, maar controleer altijd of hij ook
# helemaal klopt met je persoonlijke situatie. Ik kan niet verantwoordelijk
# gehouden worden door onjuiste configuraties etc.
#
# Dit configuratievoorbeeld komt uit een werkende opstelling met een Mikrotik
# RB2011UAS-RM. Gebruik de configuratie als leidraad.
#


# Om failover in te stellen moeten we alleen instellen dat de distance van
# verbinding A minder is dan die van verbinding B. Check-gateway zorgt ervoor
# dat de router regelmatig checked of de gateway bereikbaar is. Let erop dat dit
# alleen goed werkt wanneer je modem bridged is, dan is je gateway op het inter-
# net ipv. het lokale netwerk.
/ip route
add distance=5 check-gateway=ping gateway=1.1.1.2
add distance=10 check-gateway=ping gateway=2.2.2.3

# Als je bepaalde packets altijd over verbinding B wilt afhandelen, kan dat met
# routing marks. Dit voorbeeld markeert al het verkeer van/voor 10.0.0.1:25 met een
# 'to-xs4all' router mark. We stellen eerst de firewall in, en vervolgens een route
# om gemarkeerd verkeer af te handelen.
/ip firewall mangle
add action=mark-connection chain=prerouting connection-mark=no-mark in-interface=\
    ether2-gateway new-connection-mark=ispb-connections passthrough=no
add action=mark-routing chain=prerouting connection-mark=ispb-connections \
    new-routing-mark=to-ispb passthrough=no src-address=10.0.0.1
add action=mark-routing chain=prerouting dst-port=25 new-routing-mark=to-ispb \
    passthrough=no protocol=tcp src-address=10.0.0.1

/ip route
add distance=15 gateway=2.2.2.3 routing-mark=to-ispb